Integration
A permission error occurs even though Microsoft 365 access has been enabled
Summarize this article for me
This article describes how to resolve a permission-related problem users might encounter when trying to access Business Central records from Microsoft Teams, even though access with Microsoft 365 licenses is properly enabled in the Business Central admin center.
Symptoms
When a user selects a link or card for a Business Central record in a Microsoft Teams conversation, they receive an error message similar to "Sorry, the current permissions prevented the action."
Cause
This behaviour is by design. Administrators must first configure what data can be accessed in Microsoft Teams. If the administrator enables access in the Business Central admin center, but doesn't assign permissions on the License Configuration page, a user who tries to access Business Central records in Microsoft Teams will have their user record provisioned without permission to any objects.
Resolution
Note
To solve this issue, you need tenant administrator permissions in Business Central.
In addition to enabling Microsoft 365 access in Dynamics 365 Business Central admin center, also assign permissions on the License Configuration page. However, permissions assigned on the License Configuration page will only apply to newly created users. For users that have already been created, you must also assign the missing permissions through the Users list page.
Warnings and error messages
During your work day, you might see notifications in Business Central that something went wrong, or that it wasn't possible to post something, for example. In many cases, the notification makes it easy to resolve the matter, or to roll back any changes that you made. In other cases, you might not have the information that you need to get unblocked. This article provides tips on how to make progress.
In-product user assistance
The default version of Business Central includes descriptions for most fields, columns, and actions that can be accessed when you choose the name. In combination with teaching tips for important pages, descriptive captions, and instructional text, these tooltips, or callouts, are our current implementation of embedded user assistance, which is an important principle in today's world of software design.
If you have a question about a field or another element of the user interface, choose the name to read a short description. Choose the Ask Copilot link if that isn't enough. You can also use the in-product Help pane to find answers to your questions.
For more information, see Dynamics 365 Business Central User Assistance Model in the administration content for Business Central.
Help and Support page
In Business Central, the Help menu item (the question mark in the top right corner) gives you access to the Help and Support page, where you can find links to resources that can help you find answers to your questions. For more information, see Resources for Help and Support.
Help others
If you're an administrator or superuser, you can help others by looking up error messages in the Error Message Register page or in the administration center. In many cases, the warning or error message is about setup or lack of permission and similar issues that the superuser or administrator can easily help with. In other cases, you might have to inspect pages to identify the cause. For more information, see Finding technical information in the administration content for Business Central.
Share error details for faster assistance
To overcome obstacles and minimize downtime, apply the expertise of colleagues or subject matter experts. When an error blocks you, you can easily share the error details when you get assistance.
The details include the error message, error code, and other information that's helpful when troubleshooting an error. By sharing the error details, you can effectively communicate the specific issue you're facing, which helps your colleagues help you.
You can copy details by choosing the Share icon in inline validation dialogs, or the Share details menu in error dialogs.
In addition to copying error details, you can also choose to share details through Microsoft Teams by choosing Share details to Teams to do the following:
- Copy the error details.
- Open the Share to Teams window, where you can paste the error details you copied and specify who you want to ask for help. Business Central adds a link to the page where you experienced the error to make troubleshooting easier.
You can also choose to share details by email by choosing Share details via email to do the following:
- Copy the error details.
- Open your default email editor, where you can paste the error details you copied and specify who you want to ask for help. Business Central adds a link to the page where you experienced.
Help yourself
Error messages provide information and actions that make it easier to understand, go to, and resolve errors that come from the platform.
The error messages that the Business Central platform generates contain the full technical details, including field names, in the Detailed error message section. Select the Copy details icon on inline validation errors or in an error message to access the technical information.
Actions on error messages take you directly to the page where a field is causing the error. You don't have to take time to find the page or field yourself. To resolve the error, just choose the action in the error message and Business Central takes you to the appropriate location.
Switching to Another Company or Environment
Business Central is available in many different countries/regions and supports many different types of organizations. Your organization may choose to organize work in Business Central into multiple companies and environments. This article helps you understand the key differences and how to work across them.
About companies and environments
Business Central users sometimes support more than one department or suborganization within a business unit. For example, a business might have sales offices in different cities and multiple countries/regions, so it has created a separate business unit for each office. The offices that are in the same country/region are set up as separate companies in a shared environment. Other offices are created as companies in separate environments because they are geographically based in other countries/regions.
- What's a company?
Think of a company as a container that holds information about a legal entity. Using the example above, the business has a sales office in Seattle and another in New York, so it creates a company in Business Central for each office so that it can manage operations for each office separately.
- What's an environment?
Companies in Business Central online exist in what are referred to as environments. There are two types of environments, Production and Sandbox. In short, production environments contain live business data, and sandbox environments are used as a safe place to test things like new business processes or features. For more information, see Types of environments (in English only). If you have access to a company, you have access to the environment it's in. If you have access to more than one company, and those companies are in different environments, when you sign in to Business Central you must specify the environment that you want to work in. Environments are particular to a given country/region, so if your organization works in multiple countries/regions, you need separate environments for each country/region. For more information, see Environments and companies (in English only).
Tip
If you often switch between companies, or work with Business Central from within another app like Microsoft Teams, it can be easy to lose track of where you are. To help you keeping track, you can add a badge that will display the company name, so you can quickly verify that you're in the right place. For more information, see Display a company badge.
Depending on your browser, you can also pin the different companies to your favorites bar.
Features for switching company or environment
There are a few features you can use to switch the company or environment as you work. The following table compares the capabilities of the feature, which are explained in more detail in the sections that follow.
Feature | Switch company | Switch environment | Switch in new browser tab | Available on-premises |
|
|
|
| |
|
| |||
|
| |||
|
|
|
Use the company switcher
Using the company switcher is probably the quickest and most versatile way to switch company. The company switcher is a pane that's readily available from any page. The pane gives an overview of all companies in all environments that you have access to, and lets you switch directly to any one of them—either in the same browser tab or a new one. It's especially useful when you work in many companies across different environments.
- In upper-right corner, near the search icon, you'll see either the standard company icon, like
and
, or a custom badge for the company you're currently working with. Select the icon to open the company switcher pane.

Tip
You can also use the Crtl+O keyboard shortcut to open the pane.
- In the Available Companies pane, select the company that you want to switch to, select the Switch arrow, then choose one of the following options:
Option | Description |
Switch | Opens the role center for selected company in the same browser tab that you're working in. The company becomes the default company that opens in Business Central, until you switch again or change the company by using My Settings. |
Open in new tab | Opens the role center for selected company in a new browser tab, keeping the original company open in the other tab. |
Open in new tab and go to same page | This option is only active on list pages, like customers, sales orders, or items. It opens the same list, but for the selected company, in a new browser tab. |
Tip
Select F5 to refresh list of environments and companies.
Use the app launcher
When you're signed in to Business Central, the environments that you can access are available on the Microsoft 365.
- Select the App Launcher icon
. - In the pane that opens, look for and choose Business Central. If you don't see Business Central, choose All apps, then enter Business Central in the Search box.
- If there's more than one environment, you'll be asked to choose the environment to access.
Note
App launcher isn't available if you're signed in to Business Central as a guest.
Use My Settings
When you're signed in to Business Central, you can quickly switch to another company in the same environment. After you make the switch, the company you choose becomes your default company and will open the next time you sign in.
- In the top-right corner, choose the Settings icon
, and then choose the My Settings action.
Tip
You can also use the Alt+T keyboard shortcut to quickly open the My Settings page.
- On the My Settings page, in the Company field, select the company.
- Choose the OK button.
Tip
A good way to go directly to your default company when you sign in, and avoid having to specify an environment, is to add the URL to your list of favorites after you sign in.
Use company hub
Company hub is a highly specialized role center that gives a financial overview across companies and environments. Available as an extension, company hub provides a dashboard with summary data for each company that you have access to. The home page displays financial KPIs and a direct link to the individual environments and companies. For more information, see Manage Work across Multiple Companies in the Company Hub.
Managing Sessions in the Admin Center
For each environment in the Business Central administration center, you can use the Manage Sessions page to view information about active sessions on an environment and cancel selected sessions.
To open the page, select Manage Sessions. Use the Show session details check box to show more or fewer details.
Cancel sessions
Canceling a session is sometimes the only way to unblock a customer. For example, a long-running report is locking data in a table, preventing warehouse employees from working.
To cancel a session, select it from the list and then select Cancel selected sessions.
Restart environment
In some cases, canceling the sessions does not solve the problem. In those cases, you may want to restart the environment.
To restart an environment that is causing problems for you, go to the Manage Sessions page, choose the relevant environment, and then choose the Restart Environment action.
Important
“Make sure that all users are signed out of all companies in the environment before you restart it”.
Working with and Troubleshooting Payloads
This article provides some tips and tricks for working with and troubleshooting the printer and report payloads.
Troubleshooting printer payload errors
If a printer payload isn't valid, a runtime error occurs in the client when the OnAfterSetupPrinters event is raised. The details in the error message will depend on what action raised the OnAfterSetupPrinters event.
- If the error occurs from the Printer Selections page or the report request page, the following general error message appears:
'The data provided by the extension for a printer's setup is invalid. Please contact the developer of the extension for further assistance.'
- If the error occurs when opening a page that uses the virtual table Printer as its source, then a more detailed message displays, depending on the cause.
Refer to the Printer Payload to see the possible error messages and to help you identify and resolve these issues.
Getting more information from the Windows Event Log
If you're running Business Central on-premises, you can use the Windows Event log get more information about printer payload issues than what appears in the client. With errors related to an incorrect payload format, a warning is also recorded in the Windows Event Log of the computer running the Business Central Server. This warning provides more details than what is shown in the client. For example, let's say the client displays the following message:
'The provided payload for printer '{0}' isn't formatted correctly. Please update the payload and try again.'
Using event By Event Viewer, you would see a message like the following message:
Message The provided payload for printer '{0}' isn't formatted correctly. Details: Required property 'version' not found in JSON.
Creating a printer selection page for testing
When a page that uses the Printers system table opens, the system raises the OnAfterSetupPrinters event the Printers system table. During development, it can be useful to create a page the uses this table as its source. Once you have the page, you can run it to quickly verify the printer payloads.
For example, the following code snippet creates a page that lists extension printer setups.
page 50101 MyPrinterList
{
PageType = List;
ApplicationArea = All;
UsageCategory = Lists;
SourceTable = Printer;
layout
{
area(Content)
{
repeater(GroupName)
{
field(ID; ID)
{
ApplicationArea = All;
}
field(Payload; Payload)
{
ApplicationArea = All;
}
}
}
}
}
Unpacking detailed views of the report payload
You might want to look at the views that are in the report payload. The following code snippet unpacks the views that are in a report payload into a message:
procedure DisplayFilterView(ObjectPayload: JsonObject)
var
ViewSize: Integer;
i: Integer;
DataItemViews: JsonToken;
ViewToken: JsonToken;
ViewTableId: JsonToken;
ViewName: JsonToken;
ViewValue: JsonToken;
begin
ObjectPayload.Get('filterviews', DataItemViews);
ViewSize := DataItemViews.AsArray().Count;
for i := 0 to (ViewSize - 1) do begin
DataItemViews.AsArray().Get(i, ViewToken);
ViewToken.AsObject().Get('name', ViewName);
ViewToken.AsObject().Get('tableid', ViewTableId);
ViewToken.AsObject().Get('view', ViewValue);
Message('Name = %1, tableid = %2, Value = %3', ViewName.AsValue().AsText(), ViewTableId.AsValue().AsText(), ViewValue.AsValue().AsText());
end;
end;
Permissions Property
Sets permissions required to perform operations on one or more objects. For tables, operations can be set to read, insert, modify, and delete data. For other objects, permission can be set to allow execute on the object.
Applies to
- Codeunit
- Table
- Request Page
- Page
- Xml Port
- Report
- Query
- Permission Set
- Permission Set Extension
Syntax
The Permissions property allows you to set permissions for one or more objects.
Permissions = ObjectType ObjectIdentifier = PermissionValues [, ObjectType ObjectIdentifier = PermissionValues] ;
Property values
Values | Represents | Description |
R or r | Read | Specifies direct (R) or indirect (r) read permission. |
I or i | Insert | Specifies direct (I) or indirect (i) insert permission. |
M or m | Modify | Specifies direct (M) or indirect (m) modify permission. |
D or d | Delete | Specifies direct (D) or indirect (d) delete permission. |
X or x | Execute | Specifies direct (X) or indirect (x) execute permission. |
Example
The following AL code sets permissions to read/insert/modify/delete data in the table MyTable as well as permission to run the codeunit MyCodeUnit, open the page MyPage, and run the report MyReport.
Permissions =
tabledata MyTable = RIMD,
codeunit MyCodeUnit = X,
page MyPage = X,
report MyReport = X
Remarks
The license determines the permissions that users have in Dynamics 365 Business Central. These permissions are further refined by the security permission sets that administrators grant to users. For data, the types of access are Read, Insert, Modify, and Delete. A user with Read permission can open the page that displays the data from a table, for example, the Item or Customer tables. However, to change or delete the data the user must have Modify and Delete permissions.
Sometimes the license or permission set only give user indirect permission to perform operations on certain data in tables (TableData). A user who has Indirect Read permission cannot open a page that displays data from a table unless the page has been given permission to read data from the table for the user. That means the user can perform an action on the data only through another object (see Applies To). In other words, if you only have indirect permission to, for example, insert data into a particular table, you cannot insert data into this table from the standard user interface. You must use a database object that has been given extra permission to insert data into the table.
By default, objects do not have the permission property defined and use the same permissions as the user. However for special cases, such as various Ledger Entries tables, users do not have write or modify permissions. Instead, users should run posting routines that create ledger entries on behalf of user.
Example - Indirect Permission
You can give users access to an object, but only through another object. This is called giving "Indirect" permission. For example, a user can have permission to run codeunit 80, Sales-Post. The Sales-Post codeunit performs many tasks, including modifying table 37, Sales Line. When the user posts a sales document by using the Sales-Post codeunit, Business Central checks whether the user has permission to modify the Sales Line table. If not, the codeunit cannot complete its tasks, and the user receives an error message. If so, the codeunit runs successfully.
However, the user does not need full access to the Sales Line table to run the codeunit. If the user has Indirect permission for the Sales Line table, then the Sales-Post codeunit runs successfully. When a user has Indirect permission, that user can only modify the Sales Line table by running the Sales-Post codeunit or another object that has permission to modify the Sales Line table. The user can only modify the Sales Line table when doing so from supported application areas. The user cannot run the feature inadvertently or maliciously by other methods.
The following table illustrates how the Permission property works with the permissions granted to an object by the license or a permission set. The table shows the runtime results when the Permission property is set and when it isn't.
Permissions granted by permission set | Permission property not set | Permission property set |
None | Runtime error caused by missing permissions. | Runtime error caused by missing permissions. |
Indirect permission | Runtime error caused by missing permissions. | Success |
Direct permission | Success | Success |
The following example shows how to specify the permissions property for the codeunit used for customer ledger entries. You can define the permissions property in other objects in the same way.
codeunit 50113 CreateCustomer
{
Permissions = TableData "Cust. Ledger Entry" = rm;
TableNo = Customer;
trigger OnRun();
begin
InsertEntry(Rec);
end;
procedure InsertEntry(var Cust : Record Customer)
var
CustLedgerEntry: Record "Cust. Ledger Entry";
begin
CustLedgerEntry.Init();
CustLedgerEntry."Entry No." := 1;
CustLedgerEntry."Customer No." := Cust."No.";
CustLedgerEntry."Posting Date" := WorkDate();
CustLedgerEntry.Insert();
end;
}
Create users according to licenses
This article describes how administrators create users and define who can sign in to Business Central. This article also describes how to assign permissions to different users according to your product licenses.
Basics
- When you create users in Business Central, you grant permissions to them through permission sets.
- You can also organize users in security groups. Security groups make it easier to manage permissions and other settings for multiple users at the same time.
Security groups replace user groups starting in 2023 release wave 1 (version 22). You can keep using user groups until 2024 release wave 2 (version 25).
Security groups work like user groups. Admins assign permissions to the security group so its members can do their jobs. Learn more in Control Access to Business Central Using Security Groups.
- There are several license types. Learn about the different types of licenses and how licensing works in the Dynamics 365 Licensing Guide.
- The process of managing users and licenses varies depending on whether Business Central is deployed online or on-premises. For Business Central online, you must add users from Microsoft 365. In on-premises deployments, you can create, edit, and delete users directly.
Manage users and licenses in online tenants
User accounts in Business Central online must be first created in the Microsoft 365 admin center. These user accounts aren't exclusive to Business Central. If you subscribe to other plans, they can be used to sign in to other applications, such as Power BI. For information about creating users in the Microsoft 365 admin center, go to Add users in Microsoft admin center.
Your subscription to Business Central online defines how many Business Central user licenses you're allowed. Users are added to your tenant in the Microsoft Partner Center, typically by your Microsoft partner. Learn more at Administration of Business Central Online.
You assign licenses to users according to the work each user does in Business Central. You can assign licenses in several ways:
- Your company's Microsoft 365 administrator can do it in the Microsoft 365 Admin Center. Learn more at Add users individually or in bulk to Microsoft 365.
- A Microsoft partner can assign licenses in the Microsoft 365 Admin Center or in the Microsoft Partner Center. Learn more at User management tasks for customer accounts in the Microsoft Partner Center Help.
Learn more at Administration of Business Central Online in the administration Help.
After user accounts are created in the Microsoft 365 admin center, there are two ways to import them to Business Central:
- A user account is imported automatically when the user signs in to Business Central the first time.
Note
After a user signs in to Business Central online, you can't delete the user.
- The administrator can import users by choosing the Update Users from Microsoft 365 action on the *Users page.
Both approaches have their own advantages, and you can use them simultaneously. Each approach allows administrators to proactively configure Business Central to assign the starting permissions, user groups, and user profiles. Using the Update Users from Microsoft 365 action gives administrators more control to adjust permissions, user groups, and profiles. It's an ideal approach when you're setting up Business Central the first time, before any users sign in, or when adding a new team of users.
Note
After you add users in the Microsoft 365 Admin Center, we recommend that you update the user information in Business Central as soon as possible. Keeping user information current is easy to do, and helps ensure that people can always sign in. Learn more at To add users or update user information and license assignments in Business Central.
Updating user information is especially important if you customize permission sets for the license. If a new user tries to sign in to Business Central before you add them, they might not be able to. Learn more at Configure permissions based on licenses.
However, users who experience this problem aren't blocked. They can either use the Go back home action, or just sign in again to resolve the issue.
Delegated admin users
You might see other users in the Users list apart from those from your own company. When a delegated admin from a reselling partner company logs into a Business Central environment on behalf of their customer, they are automatically created as a user inside Business Central. This way, the actions performed by a delegated admin are logged in Business Central, such as posting documents, and associated with their user ID.
With granular delegated admin privileges (GDAP), the user is shown in the Users list and can be assigned any permissions. They are not shown with name and other personal information but with their company name and a unique ID. Both internal and external admins can see these users in the Users list, and they have full transparency into what these users do through the change log, for example. But they can't see the actual name of these users. GDAP users are listed with user names in the following format: User123456@partnerdomain.com. They might have a user name that reflects the partner's company name, and the email address is not the person's actual email address. This way, the GDAP user accounts do not reveal personal information. If you need to find out who the person behind such a pseudonym is, you'll have to reach out to the company that this user works or worked for.
Learn more in Delegated administrator access to Business Central Online.
Configure permissions based on licenses
Admins can configure permissions sets and user groups for each license.
For example, the commonly used license, Dynamics 365 Business Central Team Member, has the following permissions sets by default:
- D365 READ
- D365 TEAM MEMBER
- EDIT IN EXCEL - VIEW
- EXPORT REPORT EXCEL
- LOCAL
Other permission sets are added automatically based on the user groups assigned to the license. When you create a new user based on this license, Business Central assigns the permission sets originating from the user groups and the permission sets from the license. The same starting permissions are assigned to the user if their user account was created automatically in Business Central or if the administrator used the Update Users from Microsoft 365 action in the Users page.
If this default configuration isn't the right setup for a particular environment, the admin can change that configuration. However, customized permissions affect only new users who are assigned that license. Permissions for existing users who are assigned the license aren't affected.
- Sign in to Business Central using an administrator account.
- Select Search (Alt+Q)
in the upper-right corner, enter License Configuration, and then choose the related link. - In the License Configuration page, choose the license that you want to customize, and then choose the Configure action.
- Choose the Customize permissions field to switch on customization, and then make the changes.
In our example, the admin wants to remove the permission to edit in Excel, so they remove the Excel Export Action user group from the Team Member license. Afterward, new users who are assigned the Team Member license can't export data to Excel. If the organization changes their minds on the subject, they can just go back to the License Configuration page and switch off the customization for that license type.
Important
This customization of permissions only takes effect for new users that you assign the relevant license. Existing users aren't updated. We recommend that you customize permissions before you start assigning users licenses in the Microsoft 365 admin center.
To add users or update user information and license assignments in Business Central
After you add users or change user information in the Microsoft 365 Admin Center, you can quickly import the user information to Business Central. The import includes license assignments.
Tip
If you need to update user information and you have numerous users, you can use the filter pane to narrow down the list. You can filter on basic information such as the user name, or set more technical filters, such as the user's security ID.
- Sign in to Business Central using an administrator account.
- Select Search (Alt+Q)
in the upper-right corner, enter Users, and then choose the related link. - Choose Update Users from Microsoft 365.
Important
Running the synchronization of users from Microsoft 365 using the Update Users from Microsoft 365 guide, requires the SUPER permission set.
Note
The Update Users from Microsoft 365 guide doesn't update users that aren't assigned a license, such as someone who is a Dynamics 365 administrator. Those users will update the next time they sign in to the environment.
The next step for newly created users is to assign user groups and permissions. Go to Assign Permissions to Users and Groups for information. If you update a user with a license change, Business Central assigns users to the appropriate user group and updates their permission sets. Learn more at To manage permissions through user groups.
Note
A user with a Premium license can sign in to a company where the Experience field is set to Essentials on the Company Information page, but can't use Premium features in that company. Users with an Essentials license can't sign in to a company where the Experience field is set to Premium. Learn more in Enable Premium features.
If you use an external accountant to manage your books and financial reporting, you can invite them to your Business Central so they can work with you on your fiscal data. Learn more at Inviting Your External Accountant to Your Business Central.
To learn more about synchronizing user information with Microsoft 365, go to the Synchronization with Microsoft 365 section.
Note
If you use an external accountant to manage your books and financial reporting, you can invite them to your Business Central so they can work with you on your fiscal data. Learn more at Inviting Your External Accountant to Your Business Central.
To remove a user's access to the system
You can remove a user's access to Business Central online. All references to the user are kept. However, the user can't sign in and active sessions for the user are stopped.
- Select Search (Alt+Q)
in the upper-right corner, enter Users, and then choose the related link. - Open the User Card page for the relevant user, and then, in the Status field, select Disabled.
- To give the user access again, set the Status field to Enabled.
You can also remove the license from a user in the Microsoft 365 Admin Center. The user is then unable to sign in. Learn more at Remove licenses from users.
Synchronization with Microsoft 365
When you assign a license for Business Central to a user in Microsoft 365, there are two ways to create the user in Business Central.
- The administrator can add the user by choosing the Update Users from Microsoft 365 action on the Users page as described in the To add a user or update user information in Business Central section.
- The license information updates automatically when the user signs in for the first time.
In both cases, several settings are applied automatically. These settings are listed in the second and third columns in the following table.
If you change user information in Microsoft 365, you can update Business Central to reflect the change. Depending on what you want to update, use one of the actions on the Users page. The actions are described in the last two columns in the following table.
What happens when: | First user, first sign-in | Update Users from Microsoft 365 | Restore User Default User Groups |
Scope: | Current user | Multiple selected users | Single selected user (except current) |
Create the new user and assign SUPER permission set. | X | X | |
Update the user based on information in Microsoft 365: Status, Full Name, Contact Email, Authentication Email. | X | X | X |
Synchronize user plans (licenses) with licenses and roles assigned in Microsoft 365. | X | X | X |
Add the user to user groups according to the current user plans. Remove the SUPER permission set for all users other than the first user to sign in and administrators. At least one SUPER is required. | X | X | X |
Users can access Business Central records in Teams using only their Microsoft 365 license. When access is enabled for an environment, synchronizing using the Update users from Microsoft 365 action skips users that only have a Microsoft 365 license. To include these users in synchronization, you must first update environment settings by assigning a security group that contains users with a Business Central license and users with only a Microsoft 365 license.
Learn about securing access to environments using security groups at Manage access using Microsoft Entra groups.
Get an overview of accessing Business Central in Teams with Microsoft 365 licenses at admin-access-with-m365-license.
Manage users and licenses in on-premises deployments
For on-premises deployments, the number of user licenses is specified in the license file (.bclicense or .flf). When an administrator or Microsoft partner uploads the license file, they can specify which users can sign in to Business Central.
For on-premises deployments, the administrator creates, edits, and deletes users directly from the Users page.
Note
In Business Central on-premises, delegated admin access isn't available like it is in Business Central online. Microsoft partners need standard user licenses to use Business Central. Learn more about licenses in the Business Central on-premises licensing guide.
To edit or delete a user in an on-premises deployment
- Select Search (Alt+Q)
in the upper-right corner, enter Users, and then choose the related link. - Select the user that you want to edit, and then choose the Edit action.
- On the User Card page, change the information as necessary.
- To delete a user, select the user that you want to delete, and then choose the Delete action.
Note
For on-premises deployments, administrators can specify how to authenticate user credentials in the Business Central Server instance. When you create a user, you provide the credential type that you're using.
Learn more at Authentication and Credential Types in the administration Help for Business Central.
Analyze user status by license type
You can use the Data Analysis feature to analyze data on the Users page. You don't have to run a report or open another application, such as Excel. The feature provides an interactive and versatile way to calculate, summarize, and examine data. Instead of running reports using options and filters, you can add multiple tabs that represent different tasks or views on the data. Some examples are "Users by status" or "Users by license type," or any other view you can imagine. To learn more about how to use the Data Analysis feature, go to Analyze list and query data with analysis mode.
User analysis scenarios
The following sections provide examples of scenarios where analyzing the user list can help you monitor the status of your users.
Area | To... | Open this page in analysis mode | Using these fields |
Explore a list of users based on their status (enabled/disabled). | Status, User Name, Full Name, Authorization email, and License Type. | ||
Review a list of users based on their license type. | License Type, Status, User Name, Full Name, and Authorization email. |
Example: Users by status
To analyze users by status, follow these steps:
- Open the Users list, and choose the
icon to turn on analysis mode. - On the Columns menu, remove all columns (select the box next to the Search field on the right).
- Drag the Status (user enabled/disabled) and License Type fields to the Row Groups area.
- Choose the fields User Name, Full Name, and Authorization email.
- Rename your analysis tab to Users by status, or something that describes this analysis.
Example: Users by license type
To analyze users by license type, follow these steps:
- Open the Users list, and choose the
icon to turn on analysis mode. - On the Columns menu, remove all columns (select the box next to the Search field on the right).
- Drag the License Type and Status (user enabled/disabled) fields to the Row Groups area.
- Choose the User Name, Full Name, and Authorization email fields.
- Rename your analysis tab to Users by license type, or something that describes this analysis.
For more Details visit: https://learn.microsoft.com/en-us/
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article